Garmin nuvi 660 updating bluetooth firmware

Rated 3.96/5 based on 734 customer reviews

Yesterday, while driving around town, suddenly the Nuvi 660 gave a message that it was downloading bluetooth update. I did note easy and successful pairing with my phone afterwards. I've only had that happen after I've run the webupdater (that had a BT update on it) and installed onto my 660, then the next time I booted up my GPSr in my car I have seen BT update in progress show on the screen.There was a progress bar and after about 2 minutes it was done. I assumed that my device was just completing the BT update cycle.But your procedure worked,took a good minute for the flicker and then the Pre-Boot message to disappear,then it started loading some Bluetooth update and then came back to the normal screen.Thanks again, Siggy Your tip on holding the power button and waiting for the pre-boot sequence saved the day on my nuvi 350 when a software update to V6.0 failed and gave me the ill-fated "system software missing" error.I had updated the firmware, but that was maybe 2 weeks prior. Also at the power they transmit and the fact that users sometimes lose signals when they enter long tunnels or parking gargaes, it would seem that a sat update would not be reliable enough.All of this and they already have an update function built into the unit (Webupdater).

I hope this assists other if they encounter this problem. Strangely when it came back up the v2.7 upgrade had worked for me too.

I did this as I read some other comments that the Garmin webupdater application has (in some cases) caused corruption.

I ran the firmware update as per the instructions from the Garmin website and two files copied to the unit but the third file (I can't recall the extension) failed to copy with a file in use error.

go to the direct software update link: - Download: Nuvi 660 software update version 4.70 (4.86 MB) as of December 11, 2008 Thank you, thank you for sharing the info on holding power button down.

I just updated my Nuvi 660 from v.3.5 to v3.6 software and got the error message. Your procedure worked great,had the "System software missing" after a Webupdate_241.

Leave a Reply